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How to Mail Merge PDF Documents 
A step-by-step guide to creating personalized documents  
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What is a mail merge? 
 
Mail merge is a computer term describing the production of multiple (and potentially large numbers of) 
documents from a single template form and a structured data source. This technique is used to create 
personalized letters, documents, bills and pre-addressed envelopes or mailing labels for mass mailings 
(or document creation) from a database of names and addresses. 

What do I need to start? 
 
You need a PDF form (a PDF document with fillable fields) and a data file that contains records with 
information that needs to be placed into the form. You can use Microsoft Excel spreadsheets, Microsoft 
Access database or simply a plain text file. Let’s start from scratch and create a PDF form and a data file. 

 Step 1: How to create a PDF document? 
 
PDF form is a special kind of PDF document that contains interactive fields where text information can 
be entered or check boxes may be selected. You can create a PDF form from any PDF, word processor, 
image file or paper document. You only need to add fields to the PDF document using tools provided by 
Adobe Acrobat. Fields are interactive elements where user can either type text or make a selection.  If 
you already have a PDF document you want to use as a template, then select “File > Open” menu and 
load this document into Adobe Acrobat: 
 

  
 
If you have a Microsoft Word document, then either print it to a PDF printer or save it as PDF using 
Microsoft Word menu. You can also use “File > Create” menu in Adobe Acrobat to create a PDF file from 
many existing file formats or by scanning a paper document. 

Step 2: How to add fields to a PDF document? 
 
We are assuming that you have already created a PDF document at this point and have it open in Adobe 
Acrobat. The actual selection of steps depends on the version of Adobe Acrobat you are using. If you are 
using older versions of Adobe Acrobat, then select “Form > Edit Fields…” (or similar) from the Acrobat 
menu to start adding  fields.  
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If you are using Adobe Acrobat X, then open “Tools > Forms” panel and click on “Edit…” icon. 
 

 

Once a document is open in a form editor, click on “Add New Field” icon: 
 

 

 
 
Select a field type you want to place on the document (text, check or radio box, list box, dropdown and 
etc.) and use mouse to place it on a page. You need to press and hold left mouse button and drag mouse 
to create a box of desired dimensions. 
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Once you placed a field you should see the following: 

 
Adobe Acrobat by default automatically gives all new fields a name such as “Text1”, “Text2” and so on. 
You need to change that name to something more informative. Start typing into a “Field Name” box and 
enter a more useful field name: 

 
You will use field names later in the mail merge where it is necessary to assign what data fields are used 
to populate a specific form field. Click on “All Properties” link to open “Field Properties” dialog. 
Occasionally, you may need to change some field properties from their default values: 
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For example, if you need a form field that holds multiple lines of text, then select “Options” tab and 
check “Multi-line” option: 
 

 
 
If you want to change text font or color, then select “Appearance” tab and choose the desired settings. If 
you select “Read Only” option, then users will not be able to enter anything into this field. 
If you select “Required” option, then users will be required to enter information into this field and not 
allowed to leave it blank. 
Press “Close” button once you have finished editing all field properties. 
Repeat the above procedure for every field you need to add to this PDF document.  
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If you are planning to let recipients of this form use a free Adobe Acrobat Reader to fill and save this 
form, then you have to enable “extended rights” for this document. Do this as a last stage since once 
extended rights are enabled any changes to the document will invalidate such rights and you have to do 
it again. Depending on a version of Adobe Acrobat this option is either available via “Advanced” menu or 
if you are using Adobe Acrobat X via “File > Save As…> Reader Extended PDF > Enable Additional 
Features…” menu. Once you are done editing this form use “File > Save” menu to save it. Now this PDF 
form is ready for the mail merge. 

 Step 3: How to prepare data? 
In many cases you may already have data that needs to go into the form in some kind of spreadsheet or 
database. If you do not have one, then we are going to show how to create a very simple data file using 
just Notepad text editor. Let’s assume we are trying to fill W-2 forms for company employees. We need 
to create a data file that lists first and last name for each employee. Simply open Notepad editor and 
type the following text: 
 

 
 
Note that a first line contains comma separated field names (“First Name” and “Last Name”) while the 
rest of the file contains actual data. Make sure to separate each field by a comma or tab. You can use 
both types of files with AutoMailMerge software. Save this data file with either CSV extension (if you are 
using comma as a separator) or TXT (if you are using tab). Now all data is ready to be used for a mail 
merge. You can use Microsoft Excel to prepare your data: 
 

  
  
There is one more step that you have to do before you can use Excel spreadsheet in AutoMailMerge 
software (http://www.evermap.com/automailmerge.asp). Spreadsheet is a free-form data file unlike a 

http://www.evermap.com/automailmerge.asp
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database table or a comma-separated text file that we just created. It is necessary to create a “named 
cell range” in Excel file. Use the mouse to select all cells that need to be used for the mail merge and 
then type a name for this group of cells in the box that is located at the top-left corner of the 
spreadsheet (see where “MyData” text is displayed): 
 

 
 
In the above example,  a selected cell range is now named “MyData” and can be referred to in external 
applications such as AutoMailMerge. Save this spreadsheet using “File > Save” menu and it is ready to 
be used for a mail merge. 

Step 4: How to put data into form? 
We are assuming that at this point we have a PDF form (W2.pdf) with two text fields (“First Name” and 
“Last Name”): 
 

 
 
and a data Excel spreadsheet MyData.xls we just created at step 3. Let’s start to populate our PDF form 
with data from Excel file and create 4 new PDF documents using AutoMailMerge plug-in for Adobe 
Acrobat (http://www.evermap.com/automailmerge.asp). One output document is created for each 
record in a data file. Since we have 4 records in our test spreadsheet, then 4 personalized output files 
are going to be generated. Make sure you have either a full or trial version of AutoMailMerge software 
installed on your computer in order to perform the rest of this tutorial. 
 
 

http://www.evermap.com/automailmerge.asp
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Start Adobe Acrobat and open a template PDF form using “File > Open” menu. This will open a PDF form 
we are going to fill with data (this is a simplified W-2 form with just 2 fields): 

 
Select  “Plug-ins > Mail Merge…” from Acrobat menu to start AutoMailMerge.  
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Press “Edit Settings…” button to start configuring a mail merge: 
 

 
 
Press “Browse…” button to select a data file. You will be presented with a choice of possible input data 
source types. 
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 Since we are using Microsoft Excel 2007 spreadsheet in this tutorial select “MS Excel 2007 spreadsheet” 
from the list: 
 

 
 
Select spreadsheet in “Open” dialog: 
 

 
 



EVERMAP  [HOW TO MAIL MERGE PDF DOCUMENTS ] 
 

11 www.evermap.com 

 

Select “MyData” (or any other named cell range you have created in your spreadsheet) from a list of 
available tables: 
 

 

Press “OK” button to confirm selection. Now we have to assign correspondence between spreadsheet 
fields and PDF form fields. Simply double-click on a PDF Form field name in the list of available fields: 
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Select a data field that needs to be used to fill this form field (“First Name”) from a list of available data 
fields: 

 
Press “OK” button to make this assignment and close the dialog. Repeat last two steps for each field that 
needs to get text from a spreadsheet. You should see the following once you have completed the 
assignment: 
 

 
Each PDF form field has now a corresponding spreadsheet field assigned. Press “Next >” button to move 
to the next step once you have mapped all fields. 
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Check “Flatten output PDF documents” option if you do not want form recipients to edit content of the 
fields, otherwise leave it unchecked: 
 

 
 
Press “Next >” button to move to the next step. 
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Select output folder by pressing a “Browse…” button and selecting a desired folder: 
 

 

You can explore file naming options at this point. Leave default settings that will name each output file 
using input file name and an auto-incrementing number. For example, if you are using MyForm.pdf file 
as input, all output files will be named MyForm1.pdf, MyForm2.pdf, MyForm3.pdf and so on. Software 
offers a number of different options including using data fields anywhere in the file name. It is possible 
to automatically name output files as John Doe.pdf, Mary Smith.pdf and etc. 

Press “Next >” button to move to the next step once you are done specifying file options. 
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Actually, you can skip all remaining steps (“Add Watermark”, “Select Document Security”, “Select E-mail 
options” and “Select Advanced Actions”) by clicking on “Next >” button if you are not interested in any 
additional options. Everything is now ready for running a mail merge. 
 

 
 
Press “OK” button to start producing output documents. Press “OK” button to confirm execution: 
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You should see “Mail Merge Results” dialog once a mail merge is completed. This dialog will list any 
errors that occurred during the processing.  
 

 

Press “OK” button to close this dialog and open an output folder where generated PDF files are stored. 
Examine output files by opening them in Adobe Acrobat to see if they satisfy your requirements. Make 
adjustments to processing settings and run mail merge again, if necessary. 
 
You can read more in-depth information about various options offered by AutoMailMerge software in 
the product user’s guide. Select “Help > Plug-in > AutoMailMerge…” from Acrobat menu to access the 
software manual. 

Visit http://www.evermap.com/automailmerge.asp for a detailed product overview and to download a 
free 30-days trial version of the software. 

  

http://www.evermap.com/automailmerge.asp
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Advanced Topic: How to create multiline address labels 
One of the most common mail merge tasks is adding mailing addresses to newsletters, brochures and 
other mail correspondence. Please follow these simple steps if you want to add personalized mailing 
addresses from your customer database or spreadsheet to your correspondence.  

1. First, add a single text field to your PDF document that is going to hold a mailing address. Refer 
to the beginning of this document for detailed instructions on how to add form field to a PDF 
document. Name this text form field something like “Address”. Make sure that this text box is 
large enough to hold 4-5 lines of text. 

 
2. Right-click on this form field and select “Properties…” from popup menu. You should see a 

field’s “Text Field Properties” dialog to appear on the screen. 
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3. Select “Options” tab and check “Multi-line” option. This option will allow this field to hold 
multiple lines of text. 
 

 
 

4. Press “Close” button to close “Text Field Properties” dialog. 
5. Save your PDF document with newly added form field by selecting “File > Save As…” from the 

menu.. 
6. Select “Plug-in > Mail Merge…” from the menu to start a mail merge. 
7. Press “Edit Settings…” button to start configuring settings for the mail merge. 
8. Press “Browse…” button and select your data source file. 
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9. Double-click on the “Address” form field in the list of available fields: 

 
10. Check “Use a multi-field expression to create a composite field” option and type an expression 

such as (assuming data fields such as First Name. Last Name, Address 1 and etc. exist in your 
data file): 
[First Name] [Last Name] 
[Address 1]  
[Address 2} 
[City] [State] [ZIP] 
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12. Press “OK” button to close “Select Data Field” dialog. Complete the rest of the configuration 
wizard. Run mail merge to produce output documents. 
 
Mailing addresses in your document should look like the following: 
 

 
 
The plug-in automatically removes any blank lines in address if a certain data fields (such as 
“Address 2”) are empty. 
 
 
 
 
 
Other AutoMailMerge tutorials: 
 
“Creating and Printing Multiple Labels per Page” is available for download from 
http://www.evermap.com/AutoMailMerge/PrintingMultipleLabelsPerPage.pdf 
 

http://www.evermap.com/AutoMailMerge/PrintingMultipleLabelsPerPage.pdf
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